Amazon.com Widgets

Too old or too modern, but the site is just not very smart

17-08-2008

Thanks to the magic of Twitter @Malarkey sent a very curious message about this error message:

Error Displayed: The current browser is either too old or too modern
“The current browser is either too old or too modern”

So, the calendar can’t be used because the javascript that’s supposed to handle it was made for the Netscape Navigator browser which I imagine no one thought would ever ever go away. Unfortunately it went away in March 2008, after years of almost nil market share. Someone must have thought that people actually bothered to install the gazillions CDs that AOL polluted the world with for about a decade.

Unfortunately that was not the case and hardly anyone has used Navigator since 2002, and so what could have been seen as a bold move by the developers betting their all on the success of one single browser now survives solely as a curious error message that I think could also be a haiku.

On the other hand it could be that the error message should be “The developers of this site are either too stupid or too lazy.”

So, kids, let this be a lesson to you: don’t develop for a single browser, make sure your code degrades gracefully and, if you are the website owner, check your websites more often than once every five years, preferably with what people would most likely be using to see it.

Roberto Baca

Escribo cosas de vez en cuando